POTI改 設置サポート掲示板


[90] 急にエラーが出るようになりました。


ID:1282044d 23/03/29
エラー。本プログラムの動作には PHPバージョン 7.2.5 以上が必要です。
(現在のPHPバージョン:7.0.33)

と出ます。XREAです。

さとぴあ@管理人 ID:dd6ca656 23/03/29
PHPのバージョンが7.0.33なので、
PHP7.2.5以上にしてくださいというエラーメッセージです。
https://www.xrea.com/plan/
PHP 7.4(CGI版)
/ 8.2 / 8.1 / 8.0 / 7.4 / 7.3 / 7.2 / 7.1 / 7.0 / 5.6
(XREAで使用できるPHPのバージョン)
サーバのPHPのバージョンをご確認の上、7.2.5未満であればPHPのバージョンの切り替て頂けないでしょうか。
どうしても7.2.5以上にならない場合は、
ご利用のサーバの問題です。
あるいは、古いバージョンのPOTI-boardからバージョンアップしたら動かなくなったのであれば、サーバのコントロールパネルで、PHPのバージョンを7.4や8.1,8.2などに変更して頂けないでしょうか。
よろしくお願いします。

さとぴあ@管理人 [URL] ID:dd6ca656 23/03/29 Tool:
参考画面としてさくらのレンタルサーバの場合のPHPのバージョン切り替え画面を添付しておきます。
XREAのサーバコントロールパネルがどのような画面なのかわかりませんが、おそらく似たような設定画面があると思います。

さとぴあ@管理人 [URL] ID:dd6ca656 23/03/29
またどうしても事情があって
(現在のPHPバージョン:7.0.33)
つまり、PHP7.0でなければならないのであれば、
PHP5.6から8.2まで動作可能な
Petit Note v0.63.5​リリース
https://github.com/satopian/Petit_Note/releases/latest
こちらを使っていただくという選択肢もあります。
少し面倒ですが、POTI-boardのログファイルをPetit Note形式に変換する事もできます。

ID:1282044d 23/03/29
よく見たら、設定項目がありました。

無事に動く様に、なりました。
ありがとうございます!

[HOME / Admin]
Petit Note v0.90.5 Web Style by BASIC
OekakiApp - PaintBBS NEO , Klecks , ChickenPaint
UseFunction - DynamicPalette , luminous